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PURPOSE 
The purpose of this tutorial is to show the user how to use the MicroSim PCB Layout software to create a 
board layout and generate the files needed to manufacture the boards.  This tutorial will explain how to 
create the shortcuts needed to run the PCB Layout and Schematics software, how to create a footprint from 
a copy or from scratch, create the corresponding schematic symbols, and how to perform the autoroute 
function. 
 
 
GETTING STARTED 
Before attempting to use the PCB Layout software, become familiar with the PCB Layout User’s Guide.  
The user’s guide is called Pcburgd.pdf and can be found at g:\MsimDL71\Docs or by clicking on the start 
menu\EE Applications\MicroSim DesignLab Documentation\MSimPCB User’s Guide.  Shortcuts for the 
MicroSim Schematic and PCB programs must be created and stored in a dedicated directory.  To avoid 
software problems all file and folder names created while using the MicroSim software should be eight 
characters in length or less. 
 
To create the necessary shortcuts: 
 

1. Open Windows Explorer 
2. Go to C:\Windows 
3. Select the msim.ini file 
4. Copy it to a dedicated folder 
5. Go to g:\MSimDL71 folder 
6. Use the CTRL key to select the PCboards.exe and the Psched.exe files 
7. Copy these files to the dedicated directory 
8. Select the PCboards.exe file  
9. Right click and select Create Shortcut 
10. Select the new shortcut and right click 
11. Select Properties from the menu 
12. Click on the Shortcut tab 
13. Change the Target to G:\MSimDL71\PCBOARDS.EXE –i h:\full path name to dedicated 

folder\msim.ini 

 
14. Then repeat the procedure for Schematics 
15. Change the Target to G:\MSimDL71\PSCHED.EXE –i h:\full path name to dedicated 

folder\msim.ini 
 



 

 
16. Delete the original copies 
17. Rename the shortcuts Schematics and PCBoards 

 
Once this is done, you will be able to launch PCB Layout and Schematics from your dedicated folder.  
Launching from your folder will allow the programs to find the libraries you create by reading the modified 
Msim.ini file.  If these programs are launched from the start menu, an error will be generated stating that 
the program cannot find the customized part libraries.   
 
 
CREATING CUSTOM FOOTPRINTS 
If you plan to use a component that is not included in or you cannot find in the Microsim libraries, you will 
have to create a custom footprint for your component.  The footprint must be created before you try to 
develop the schematic version of your circuit.  To create a custom footprint, launch PCB Layout from the 
shortcut you created in the dedicated folder.  Once the PCB Layout program is open, go to the Library pull-
down menu and select Footprint Editor.  A new window is opened.  Now that you are in the Footprint 
Editor, you can create your own footprint by starting from scratch or by copying an existing footprint and 
modifying it. 
 

 
 



Footprints Using “Copy” 
To create a footprint from an existing footprint, open the Footprint Editor and select Copy from the 
Footprint pull-down menu. 

 
Then click on Select Library and browse the libraries (G:\MSimDL71\lib) for an existing part.  Select the 
“Connect” library. Select HDR20, change the New Footprint Name to Toggle, and hit OK.  The existing 
footprint is placed in your window. 

 
Select Layer Display from the Configure menu and then click on Unselect All.  While the layer display 
window is open, highlight the silk top layer and then click on the Make Current button and then OK. 

 



 
The silk top layer boundary and REFDES should be the only items on the screen. 

 
Delete the boundary and leave the REFDES.  Then select the Assembly Top layer from the toolbar and 
delete the boundary only. 

 
The next layer is the Boundary Top layer.  Select the boundary and delete it. 
 

 
Now select the Component layer from the toolbar and adjust the pin separation and number of pins to meet 
the specifications of your component.  For the toggle switch, you need three pins about 150mil apart.   
 
 
 
 



 

 
Double click on the individual pins and make sure that the pins are labeled as you need them to be.  This is 
important when you create a part in the Schematic Capture program; the pinout of the footprint must be the 
same as the pinout of the schematic symbol.  When you double click on the pins, an attribute window pops 
up that will allow you to change the pin number and the size and shape of its padstack.  To see a list of 
available padstacks, go to the window in the toolbar that says TRACE_STD.  To the left of this box there is 
a button with two circular arrows, click on this button until the box says rnd-040-020.  Next, click on the 
arrow to the right of the box and the list of available padstacks appears.  Find one that will work for your 
application and then double click on the pin you want to change and enter the size and style you want the 
padstack to be changed to.  For the toggle, make the padstacks sq-060-040. 
 

 



 
 

Once the pins are located properly, follow these steps: 
 

1. Go to the Configure menu and select Layer Display (or hit F3).  Select Unselect All and then 
hit OK.  Return to the layer display box in the toolbar and select Component, this should 
show all of the pins.   

2. Select the Silk Top layer.  Go to the Draw menu and select Rectangle.  Click on the point that 
you want to be the first corner of the rectangle and then the second corner.  There should now 
be an elastic line.  Use this to complete the rectangle.  Make the rectangle large enough to add 
two mounting holes for the switch.  The dimensions of the switch were taken from the parts 
catalogue.  The silk top rectangle does not have to be the same as the other layers.  The silk 
top layer is everything that will be printed on your board in white paint.   

3. Select the Assembly Top layer and repeat the procedure from the silk top.  The assembly top 
rectangle should contain all of the component pins within it. 

4. Select the Boundary Top layer and draw another rectangle over the assembly top rectangle. 
5. Go to the Draw menu and select either Machine Placement Center or Machine Center by 

Coord.  Machine Placement Center will allow you to manually place the center and the 
Machine Center by Coord will allow you to type in the coordinates for the center of your 
footprint. 

6. Now go to Add Via from the Draw menu. 
7. Place two vias about 200 mils apart (If you were actually going to use this footprint on a 

production board you would need to know exact placement of pins and dimensions) 
8. Double click on the pins and change them to square vias 

 

 
 



9. Go to File/Save As and type in the name of the component, browse for your dedicated folder, 
and enter a name for your custom library. 

 
 
Footprints From Scratch 
To create a footprint from scratch, go to the Footprint pull-down menu and select Set Name.  Name your 
component (keep the name 8 characters or less).  Then complete the following steps. 
 

1.  Change the grid spacing to the desired pin separation by clicking on the arrow next to the box 
that says “50mil.”  If your pins should be 100 mil apart then you would select 100mil from the 
pull-down menu. 

2. Go to the Draw menu and select Pins.  A window will appear and ask you for the number of 
pins to draw and if you want the auto-complete function enabled.  Enter the number of pins 
your component has and make sure the enable box is checked.  Click on OK and a pencil 
appears on the screen.  Use the pencil to place the first three pins in the pattern you want and 
the auto-complete will add the remaining pins following the same pattern.  For the power 
header, you need two pins. 

 
3. Go to the Draw menu and select Footprint Origin.  Place the cross hairs over Pin One and 

click.  The rest of your footprint will be oriented using Pin One as the origin. 

 
4. Go to the Configure menu and select Layer Display (or hit F3).  Select Unselect All and then 

hit OK.  Return to the layer display box in the toolbar and select Component, this should 
show all pins.   

5. Select the Silk Top layer.  Go to the Draw menu and select Rectangle.  Click on the point that 
you want to be the first corner of the rectangle and then the second corner.  There should now 
be an elastic line.  Use this to complete the rectangle.  The silk top rectangle does not have to 
be the same as the other layers.  The silk top layer is everything you want to be printed on the 
board in white paint.   

6. While in the silk top, go to the Draw menu and select REFDES Template.  Place the 
REFDES near the boundary of your component.  Then double click on the REFDES and click 
on the display button.  Take note of the numbers present and highlight the Assembly Top 
layer.  Insert the numbers into the appropriate categories.  Click on Assign to Layer and then 
OK. 

7. Select the Assembly Top layer and repeat the procedure from the silk top.  The assembly top 
rectangle should contain all of the component pins within it. 



8. Go to the Draw menu and select TYPE_NAME Template.  Place it near the boundary of your 
component. 

9. Select the Boundary Top layer and draw another rectangle over the assembly top rectangle. 
10. Go to the Draw menu and select either Machine Placement Center or Machine Center by 

Coord.  Machine Placement Center will allow you to manually place the center and the 
Machine Center by Coord will allow you to type in the coordinates for the center of your 
footprint. 

 
Now you need to save this footprint to the library that you created for your custom footprints.  To do this, 
go to Footprint\Set Name and enter the name of your component. Then go to Footprint\Save to Library 
and browse for your dedicated folder.  Enter the name of your custom library.  Once you have completed 
these steps, you should have a footprint for a two pin header and a three pin toggle switch with two 
mounting holes in your library.  To edit your custom footprints you have to open the Footprint Editor then 
open your library.  Once your library is open, go to Footprint\Get.  A list of the footprints in your library 
should appear.  Select the footprint of the component to be edited.  Then make the necessary changes, and 
save the footprint. 
 
To add new custom footprints to your library you should open the Footprint Editor and then select 
File\Open from the pull-down menus.  Browse through the folders until you find the dedicated folder that 
contains your customized library.  Once you have found your library select it and click OK.  The window 
should now say the name of your library and then “:unnamed1” in the blue title bar.  From this point, you 
can either copy or create a new footprint in the same manner as described previously.  Save the footprint in 
the same manner as for the power header.  This will place the new footprint into the library without 
replacing the footprints already contained in your library. 
 
To be able to use your new footprints in the Schematic capture program, or in PCB layout, you must open 
the PCB layout program and select Setup from the Library menu.   
 



 
Select Setup Footprint Libraries from the new window, and then browse the files until you find your 
library.  Once you have found your library, highlight it and click on the Add button and then OK.  If you 
have done it correctly, your library name will appear at the top of the Footprint Libraries window.  If it 
does, click OK, if it doesn’t, try again. 
 
 
 
 
 
 
 
 
 
 
 
 
CREATING SCHEMATIC SYMBOLS 
The next step is to create schematic symbols to go along with your footprints.  Use Windows Explorer to 
open the dedicated folder and launch the schematics program.  Then go to File\Edit Library.   

 
The Editor window appears as shown.  Go to Part\Wizard and follow the steps.  The first step is to name 
the new symbol.  We used the same name as our footprints.  In the Symbol Description box, type a brief 
description that will be shown when you are selecting parts later. 
 
 
 
 
 
 
 
 
 
 
Next, the wizard will ask for the symbol shape.  We used a generic rectangle for all of our parts. 

 



Then it will ask you to add pins.  There are two ways to do this.  In the current window you can add 
individual pins, which would be fine for a three pin toggle switch, but not for a complex part with many 
pins.  The second choice is to use the Add Multiple button.  This window allows you to add as many pins 
as you want at once. 
 
 
 
 
 
 
 
 
 
 
 
   
 
 
 
 
Once the pins appear, they can be moved to other sides of the symbol by highlighting the pins to be moved 
and then clicking on the arrows in the lower right corner of the window.  The pin order can also be 
rearranged by highlighting a pin number and then using the arrows to move the pin into the correct 
position. 
 
The next screen will let you select the type of pins to be added.  For our circuit, we didn’t need to do any 
simulation so we chose bi-directional pins for all of our symbols.  To do this, click on Select All and then 
Change Pins.  Another window will open.  Select All again and then change the Pin Function box to 
“bidir.” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
When you click OK, the Review Pins window will return showing the change in the ERC column.  Then 
click OK, and the Setup Packaging window appears.  We never changed this, click Next. 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
The next step is to specify which footprint to use for the new symbol.  You should be able to browse and 
find your custom footprints.  For the inverter, we created a symbol because in the schematics program the 
inverter is an individual inverter instead of a chip.  The inverter is a standard pinout, so we used the DIP14 
footprint.  For the toggle, we browsed to find the toggle footprint. 
 
 
 
 
 
 
 
 
 
 
 
 
 
The next step is to save the new symbol library.  The window will ask where you want to save the library.  
Browse to make sure that you are in the dedicated folder and then name your symbol library and save it. 

 
For the next step, browse until you find the library you just created and click Next for the remaining 
windows until you reach the end. 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Once you have completed the symbol, close the Library Editor and click Yes to both windows that appear.  
If you don’t add the library to the configured libraries, you won’t be able to place your parts into the circuit. 
 
 
 
 
 
 
 
 
 
 
 
 
USING SCHEMATIC CAPTURE 
Now you should be able to use the Schematics program to connect all of your components.  To insert parts, 
go to Draw\Get New Part.  The basic browser will open.  For convenience, click on the Advanced button.  
This allows you to see the part before placing it into your circuit.  Select the part you want and click on the 
Place & Close button.  If the part is one that you have created, click on the Libraries button and find the 
name of your library. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Once you have all of your components placed where you want them connect them in the appropriate way.  
The placement of the components is not critical because the PCB Layout placement will not be the same 
initially. 



 
When everything is connected, save the file into your dedicated folder.  Then go to Tools\Run PCBoards.  
A warning appears asking if you want to “package” the schematic.  Click No.  Then it will ask if you want 
to update the netlist.  Click Yes.  If you have any Vcc or gnd components connected in the schematic a 
warning will be given stating that the simulation components were ignored.  The PCB Layout software will 
be opened and your circuit will appear in the “ratsnest” form.  

 
From here, you have to separate the components.  If this was for a real board layout, the spacing would 
have to be exact, but for this example, we just separated them enough to see the connections clearly.   

 
Next, we added the two pin header for the power and ground connections.  To add the component go to the 
Draw menu and select Add Component and type the footprint name into the box. 
 



 
The two pin header footprint should appear.  Place it where you want and then connect the pins to the 
corresponding component pins using the Draw\Connection option.  Now you can prepare the circuit for 
autoroute.  For our example we will make the power and ground traces thicker than the signal traces.  To do 
this you need to know which “net” contains your power and ground connections.  To find out which “nets” 
you need go to View\Highlight Net.  This window allows you to highlight the connections one net at a time 
until you find the power and ground nets. 

 
When you find the nets you need, remember them and click on the Tools pulldown menu.  Go to CCT: Net 
Rules.  This window lets you set the properties of individual nets and to select which nets will be 
autorouted.   

   
For our example, the power and ground nets were 0 and NN_001 so we highlighted them in the box on the 
left, then entered “40mil” into the Set Width box, and then clicked on Set Width.  We then entered “15mil” 
into the Set Clearance box and clicked the button.  In order to only autoroute the power and ground paths, 
we have to select all other nets and select the On circle and then click the Set Fixed button.  The selections 
we made will autoroute the power and ground paths with 40mil thickness and 15mil separation, but will 
leave all other traces un-routed.  The rules we set should appear in the Rules box.  Click OK. 



 
The next step is to select Tools\CCT: Setup.  This window allows you to set the trace width and spacing of 
the paths to be created and to select the connection style, starburst or daisychain.  Since we have set the 
trace width and spacing of the paths that will be routed, we only need to select the style.  For the power and 
ground paths that are connected one pin to the next, the daisychain option is best. 

 
Once this is done you are ready to autoroute the board.  Go to Tools\CCT: Autoroute.  A new program 
window is opened and the program begins changing the thin connections to the thick traces. 
 
 
 
 
 



 
 
It will continue to try different paths until there are no conflicts and then it will return you to the PCB 
layout software. 
 

 
Now the power and ground traces are done.  The red traces are on the top layer of the board and the blue 
ones are along the bottom side.  The signal traces are still in the ratsnest connection form.  To perform the 
autoroute on these connections, return to the CCT: Net Rules window and delete the rules previously set.  
Then select the power and ground nets and use the Set Width button to fix the nets.  This will allow you to 
do the autoroute again without changing the power and ground traces.  Then open the CCT: Setup window, 
set the trace width and separation to the desired amount, and change the style to starburst.  Then run 
autoroute again.  If the trace separation is too close there is a greater chance of shorts occurring on the 
board. 
 



 
Now the board layout is complete.   
 
 
PREPARING FILES FOR THE PCB HOUSE 
The files the manufacturer will need depends on the board house, but most will ask for the gerber files, the 
aperture list, and the NC drill file.  To create these, start with the gerber files.  Click on the File pulldown 
menu and select PhotoPlot\Plot.  A window will open that says Auto Photoplot Job.  You don’t want that.  
Click on the Job Setup button.  Click on the New button. 
 
 
 
 
 
 
 
 
 
 
The New Job window lets you pick the type of new job.  Select PhotoPlot.  The next window lets you 
Define Pages.  Each page will have its own gerber file.  We defined five pages using the Board Outline 
layer in all of them.  Highlight the Board Outline and the Mask Top then click New.  Next, highlight the 
Board Outline and the Silk Top and click New.  Repeat this process for Component, Solder and Drill layers.  
You should end up with five pages.  Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Then make sure that the job you created is highlighted in the following windows and click OK.  The gerber 
files should be created.  Check your folder to see if there are any “.gxx” files.  Next return to the File menu 
and select Reports.  

 
Click on Aperture Information and OK.  There should now be a “.apr” file in your folder.  We also went to 
the PhotoPlot menu and selected Apertures then clicked on Auto and OK.  We weren’t sure we needed 
this, but we did it just in case it made a file that they needed.  Then we selected NC Drill from the File 
menu and clicked on Output.  Then clicked OK and a “.d01” file was in our folder.  The last file we needed 
was a readme text file; the manufacturer requested this file and told us what to say in it.  We created it and 
then zipped all of the files to send off. 

 


